Facebook Pages: some Data Sources show “Missing Scopes” error
Incident Report for Databox
Resolved
We have implemented another improvement which resolved the issue for the remaining Facebook Page Data Sources.

When reconnecting the Facebook Page Data Source, the new Token is set and Data Sources stay connected.
Posted Oct 22, 2020 - 03:59 EDT
Update
We've implemented an improvement which sets a new connection Token when the Facebook Pages Data Source is reconnected. This means that reconnecting the existing Data Source, which is in "Missing Scopes" error resolves the issue for the majority of Data Sources.

The issue is still present for some Data Sources, even when they are reconnected and new connection Token is set. We'll continue working on resolving the issue for all Data Sources which are in the "Missing Scopes" error.

Possible solution:
For Facebook Pages Data Sources where reconnection doesn't resolve the issue, connecting the same account as a new Data Source should help.
Posted Oct 19, 2020 - 04:56 EDT
Identified
Some Facebook Pages Data Sources are showing the “Missing Scopes” error. This issue is not related to the Custom Date Range releases and a small percentage of Facebook Pages Data Sources is affected.

We have found that the error is being returned only when the Data Source is connected with users who have the following permissions within Facebook:
- Admin, and
- Manage Page.

We believe that Facebook deprecated some settings on their end and replaced it with new permissions. We are currently working on resolving the issue with Facebook support and have not yet confirmed the cause.

TEMPORARY SOLUTION
A temporary solution is to reconnect the Data Source with a user who has any of the following roles, but also the Manage Page filter disabled:
- Analyst role,
- Employee,
- Finance Analyst, and
- Finance Editor access.
Posted Oct 14, 2020 - 08:19 EDT
This incident affected: Data & Sync Platform.