LinkedIn Pages and LinkedIn Ads connectivity issues on the API level
Incident Report for Databox
Resolved
This is resolved. All LinkedIn Company Pages and LinkedIn Ads Data Sources can be re-connected or connected from scratch without experiencing any errors anymore.

Previously, the errors "Insufficient permissions" or "Access Revoked" were shown every-time a new LinkedIn Data Source was connected or existing ones were reconnected to Databox. The issue was caused by the access tokens expiring and, therefore, being revoked. This was happening because we were using the same access app for LinkedIn Company Pages and LinkedIn Ads, which interfered one with another and caused permission errors. We have now separated both apps into 2 separate apps to prevent any interference between them.

USER ACTION: For existing LinkedIn Data Sources that are still in error, please reconnect it with a LinkedIn user that has enough permissions.

If any of our users should be experiencing any other errors, please reach out to us asap via help@databox.com.
Posted Dec 17, 2019 - 07:28 EST
Update
We are still in contact with the LinkedIn team in order to resolve those issues which originate on the API level.

As of now, LinkedIn Company Pages and LinkedIn Ads Data Sources can still be affected.
Posted Dec 06, 2019 - 09:11 EST
Identified
We have identified an issue where LinkedIn Company Pages and LinkedIn Ads Data Sources can get disconnected from Databox and showing a "Revoked access" or "Connection revoked" error or any other similar permissions error.

The issue is caused on the LinkedIn API level. We are already in contact with the LinkedIn team to troubleshoot this and help resolve the issue.
Posted Nov 29, 2019 - 06:34 EST
This incident affected: Data & Sync Platform.