Scheduled Maintenance of the Reports feature
Scheduled for Oct 24, 02:30 - 03:00 EDT
Update
Due to logistic reasons, we are moving the maintenance of Reports to Thursday, October 24. Maintenance activities will start at 2.30 AM EDT (8.30 AM CET) and will take place for 30 min.
Posted Oct 22, 2024 - 11:52 EDT
Scheduled
On Wednesday, October 23, starting at 2.30 AM EDT (8.30 AM CET), we will be performing maintenance activities on the Reports feature for a duration of approximately 30 minutes.

During the maintenance issues can occur with editing Reports and the feature may be temporarily unaccessible.

We appreciate your patience and understanding. If you have any questions or if you experience any issues after the maintenance period, please reach out to our Support team via chat or at help@databox.com.
Posted Oct 21, 2024 - 15:19 EDT
This scheduled maintenance affects: Databox Web Application.