Possible loading performance delays with the Databox WebApp
Incident Report for Databox
Resolved
The host has resolved the issue and the Databox WebApp is operating fine again.
Posted 22 days ago. Sep 01, 2019 - 03:34 EDT
Identified
We are experiencing server performance delays which impacts the Databox WebApp accessible at app.databox.com.

We are waiting for the host to resolve this.
Posted 22 days ago. Aug 31, 2019 - 10:48 EDT
This incident affected: Databox Web Application.