App inaccessible

Incident Report for Databox

Resolved

Issue is resolved. If you still experience any issues, please reach out to our Support services.
Posted 10 months ago. Jun 20, 2024 - 05:07 EDT

Investigating

App is currently inaccessible. We're addressing the matter and will share updates soon.
Posted 10 months ago. Jun 20, 2024 - 04:58 EDT
This incident affected: Databox Web Application.