Long loading time and an error when loading Query Builder
Incident Report for Databox
Resolved
We've monitored the behavior over the weekend to confirm the issue is resolved. Query Builder is loading as expected since the fix was implemented, on Friday, November 20.
Posted Nov 23, 2020 - 05:39 EST
Monitoring
We identified an issue with the Query Builder feature. We have already applied a fix, which resolved it.

The Query Builder was either loading very long (50+ sec) or didn't load and returned an error.
When the Query Builder page was opened, and a Data Source selected it took longer time to load. On the next step, when the Metric dropdown was clicked, a timeout message was returned and Metrics in the dropdown not displayed.

All users who were editing Custom Queries were affected.
Posted Nov 20, 2020 - 08:28 EST
This incident affected: Databox Web Application.