Pipedrive Data Sources in "Unauthorized" error
Incident Report for Databox
Resolved
We have been monitoring the improvement and there was no new Pipedrive Data Source disconnection with the "Unauthorized" error since the implementation.
Posted Mar 04, 2021 - 02:17 EST
Monitoring
We gathered additional information from the Pipedrive team, and have implemented a fix, which resolved the issue with some Pipedrive Data Sources getting disconnected.

We'll be monitoring the connections and are working on post-mortem.

The issue affected part of existing Pipedrive Data Sources, which got randomly disconnected with an "Unauthorized" error message.
Posted Mar 03, 2021 - 06:33 EST
Update
We are still working with the Pipedrive team on finding the solution for the disconnections. Only part of Pipedrive Data Sources is affected. The majority is successfully connected and syncing data as expected.
Posted Feb 19, 2021 - 05:50 EST
Update
We are still in communication with the Pipedrive support team and are working to get this resolved.
Posted Feb 03, 2021 - 06:53 EST
Investigating
Pipedrive Data Sources can get randomly disconnected due to issues with the refresh token. Even when reconnecting the Data Source, the connection can drop out after some time.

The issue can be identified by seeing an "Unauthorized" error for the Pipedrive connection. There is currently no temporary workaround for this.

We are already working with the Pipedrive support team to get this resolved asap.
Posted Jan 28, 2021 - 12:37 EST
This incident affected: Data & Sync Platform.