Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 01, 2024 - 01:00 EST
Scheduled
On Saturday, November 30, and Sunday, December 1, 2024, between 1.00 AM and 2.00 AM EDT (7.00 AM and 8.00 AM CET), we will be performing scheduled maintenance on the Databox platform.
During this time, minor delays can occur with data syncing.
We appreciate your patience and understanding. If you have any questions or if you experience any issues after the maintenance period, please reach out to our Support team via chat or at help@databox.com.
Posted Nov 29, 2024 - 06:38 EST
This scheduled maintenance affected: Data & Sync Platform.