Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 13, 2024 - 02:00 EDT
Scheduled
On Tuesday, August 13th, starting at 2.00 AM EDT (8.00 AM CET), we will be updating the Databox webapp. The release of updates will take 2 hours.
The scheduled release will improve the loading speed of the Databox app and provide faster response times for our users.
During the maintenance issues can occur in the app, such as features not being responsive or not loading properly. A maximum downtime of 30 minutes is possible for the app.
We appreciate your patience and understanding. If you have any questions or if you experience any issues after the maintenance period, please reach out to our Support team via chat or at help@databox.com.
Posted Aug 12, 2024 - 04:08 EDT
This scheduled maintenance affected: Databox Web Application.