Resolved: Slow loading times and timeouts with Query Builder for Google Ads, Facebook Ads and Google Analytics
Incident Report for Databox
Resolved
We resolved the issue yesterday, but continued to monitor the behavior of Query Builder. The Query Builders for Google Ads, Facebook Ads and Google Analytics continued to load as expected since the yesterday.

Affected Data Sources were: Google Ads, Facebook Ads and Google Analytics that have Custom Date Range enabled.
Posted Sep 17, 2020 - 05:40 EDT
Monitoring
We have implemented several improvements that resolved the issue with slow loading times and timeouts with Query Builder. The Query Builders for Google Ads, Facebook Ads and Google Analytics are now loading as expected.

We'll continue monitoring the behavior to make sure the loading time is as expected.

Affected Data Sources were: Google Ads, Facebook Ads and Google Analytics that have Custom Date Range enabled.
Posted Sep 16, 2020 - 05:49 EDT
Identified
We’re experiencing slow loading times and timeouts with Query Builder for Data Sources with enabled Custom Date Range. The issue can be identified as Query Builder form not loading or a timeout message appearing.
Our team is already working on resolving this.

Affected Data Sources: Google Ads, Facebook Ads and Google Analytics that have Custom Date Range enabled.
Posted Sep 11, 2020 - 09:19 EDT
This incident affected: Data & Sync Platform.