Issue has been resolved. The app can now be accessed normally.
Thank you for your patience and understanding on the matter. If you have any questions, please reach out to our Support services via chat or help@databox.com.
Posted Oct 07, 2025 - 10:32 EDT
Monitoring
We've addressed the matter and the app can now be accessed normally. We're still monitoring the app accessibility.
Posted Oct 07, 2025 - 10:14 EDT
Investigating
We've identified issues with accessing Databox app. Users might experience issues with accessing the app, reloading certain pages, moving between different pages in the app.
We are looking into the matter and will keep you posted on our findings.