Temporary loading delays with Scheduled Snapshots
Incident Report for Databox
Postmortem

Upon more investigation, we have identified that the issue caused some users/recipients to receive several duplicated emails. Affected were mostly users that had the email scheduled to be sent on the 1st of the month and are in front of the UTC time zone (e.g. UTC/GMT +9:00).

We will be reaching out to all affected users to notify them of this incident.

Posted Aug 03, 2020 - 03:32 EDT

Resolved
All Scheduled Snapshots will again be sent as expected, without any delays.

We'll also be working on improving the platform to prevent any similar incidents.
Posted Jul 31, 2020 - 19:25 EDT
Investigating
We are experiencing temporary loading delays with Scheduled Snapshots. It's possible that snapshots will be sent with a delay.

Our team is already looking into this.
Posted Jul 31, 2020 - 13:53 EDT
This incident affected: Databox Web Application.