Degraded performance and error messages when selecting Metrics and Dimensions with Custom Date Ranges and delayed email notifications
Incident Report for Databox
Resolved
We've successfully monitored this and can confirm that this is now working as expected. We are already working on the post-mortem.
Posted Feb 16, 2021 - 07:49 EST
Monitoring
We've resolved the issue and the performance is back to normal. Databoards, Metrics and Dimension dropdowns are loading as expected.

Email notifications are being delivered now too.

We are continuing to monitoring the platform to make sure the performance is stable.
Posted Feb 12, 2021 - 07:12 EST
Identified
We have noticed degraded performance for user interactions for Data Sources that have the Custom Date Range enabled.

You can identify this issue by seeing longer loading times or error messages when choosing a Metric or Dimension and when running or editing Query Builder Metrics.

The syncing itself is NOT affected and all Metrics continue to sync as expected.

Delivery of email notifications is also delayed (Scorecards, Scheduled Snapshots, Signup emails, etc.)
Posted Feb 12, 2021 - 06:38 EST
This incident affected: Databox Web Application.