Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 25, 2025 - 01:00 EDT
Scheduled
We will be performing scheduled maintenance on the Databox platform on Saturday, October 25th, starting at 1:00 AM EDT (7:00 AM CET). The maintenance window is expected to last approximately 3 hours.
During this time, Databox may be temporarily unavailable for up to 20 minutes.
We appreciate your patience and understanding as we work to keep our platform reliable and secure. If you have any questions or experience any issues after the maintenance, please contact our Support team via chat or at help@databox.com.
Posted Oct 21, 2025 - 06:37 EDT
This scheduled maintenance affected: Data & Sync Platform, Databox Web Application, and Mobile.