Databox analytics app inaccessible

Incident Report for Databox

Resolved

App is operational and accessible.
We are taking steps to prevent similar occurrences in the future.

Thank you for your patience and understanding. If you have any questions, please reach out to our Support services via chat or help@databox.com.
Posted Jun 25, 2025 - 16:11 EDT

Investigating

We are experienceing a larger issue - Databox analytics app currently cannot be accessed.
We are looking into the matter and will share updates soon.
Posted Jun 25, 2025 - 15:55 EDT
This incident affected: Databox Web Application.