Issues with Xero integration

Incident Report for Databox

Resolved

After monitoring the Xero integrations for a while, we can confirm that the issue is resolved.

The Xero data sources are now connected, new Xero connections can be added and data is syncing normally for Xero metrics.

Thank you for your patience and understanding on the matter. If you have any questions, please reach out to our Support services via chat or help@databox.com.
Posted Oct 06, 2025 - 04:48 EDT

Monitoring

Xero has resolved the issue on their end. The connections for the Xero data sources will be re-established in the following hours and then data will start syncing again.

We're currently monitoring the Xero connections.
Posted Oct 06, 2025 - 03:10 EDT

Investigating

We are currently experiencing issues with Xero integration, where we’re receiving 'Access denied' errors from Xero API.

Impact on our users:
- All syncs for Xero metrics are failing, so data is not updating for any Xero data sources.
- New Xero data source cannot be connected.

We'll be reaching out to Xero to address the matter. All updates on the matter will be shared here.
Posted Oct 02, 2025 - 09:59 EDT
This incident affected: Data & Sync Platform.