Outgoing Email Delays

Incident Report for Databox

Resolved

The issue affecting outgoing emails has been resolved. Scheduled notifications, password reset emails, and user invitation emails are sending normally. We will continue monitoring.
Posted Mar 06, 2026 - 12:10 EST

Investigating

We are currently investigating an issue affecting outgoing emails. This includes scheduled notifications, password reset emails, and user invitation emails.

Our team is actively working on a fix and this is our top priority. We will provide updates as the situation develops.

We apologise for the inconvenience.
Posted Mar 06, 2026 - 06:14 EST
This incident affected: 3rd-party API Data providers.