The majority of the 'Temporary Api Limit' error messages have subsided. We have identified that this behaviour first appeared for many GA4 metrics on March 25, between roughly 2 PM EDT and 3.30 PM EDT (7 PM CET - 8.30 PM CET). Today, on March 26, the behaviour was present roughly between 12.20 PM EDT and 2.15 PM EDT (5.20 PM CET - 7.15PM CET).
We're monitoring the situation in case the behaviour re-occurs.
Posted 13 days ago. Mar 26, 2025 - 16:36 EDT
Investigating
We have identified an increase of the 'Temporary Api Limit' error messages on the Google Analytics 4 metrics in Databox. Since we found no issues in the Databox app and the error messages are the result of actual API responses, we've concluded the behaviour is most likely caused by an issue on the side of GA4. This is further supported by error messages noticed in GA4 accounts that we are using.
We will continue to monitor the situation.
If you have any questions, please reach out to our Support services via chat or help@databox.com.
Posted 13 days ago. Mar 26, 2025 - 15:25 EDT
This incident affected: 3rd-party API Data providers.