Syncing delay for Google Analytics
Incident Report for Databox
Resolved
The sync delay for Google Analytics Data Sources is resolved. All Google Analytics Metrics are syncing as expected now.

We have implemented several improvements over the last period, which all reduced the sync delay. We've also monitored the impact of these improvements to confirm that the delay is resolved.
Posted Nov 03, 2020 - 09:48 EST
Monitoring
We've implemented additional improvements during this week which further improved the syncs of Google Analytics Data Sources.
Posted Oct 31, 2020 - 06:38 EDT
Update
We implemented an improvement last Friday, October 23. The sync delay for Google Analytics Data Sources is further reduced, and we're monitoring the effects of the latest improvement.
Posted Oct 26, 2020 - 09:38 EDT
Update
We have continued working on the permanent solution to address the sync delay for Google Analytics Data Sources, which is still present. ETA for implementing the solution is this week.

The sync delay for Google Analytics Data Sources is in the range of several hours.
Posted Oct 19, 2020 - 09:06 EDT
Update
We've implemented another improvement and resolved the syncing delay for Google Ads Data Sources.

The sync delay is now only present for Google Analytics, and we'll continue working on resolving this issue with the highest priority.
Posted Oct 14, 2020 - 11:50 EDT
Update
We've implemented additional improvements and the sync delay is resolved for the following Data Sources: Google Search Console, Google My Business, Facebook Pages, Facebook Ads, Instagram Business, Twitter, LinkedIn Company Pages, Ahrefs.
These Data Sources are syncing as expected.

The sync delay is still present for Google Analytics and Google Ads. We're working on additional improvements in order to resolve the sync delay for these two Data Sources.
Posted Oct 14, 2020 - 06:49 EDT
Update
We have implemented a few improvements which are reducing sync delays.

Most improvements are affecting Facebook Ads, Instagram Business, Google Search Console, Twitter, LinkedIn Company Pages, and Google My Business, where syncs are back to usual schedule and Databoards are expected to show updated values with the next scheduled sync (hourly or daily).

We are still working on improvements for Facebook Pages, Google Ads, and Google Analytics, where there are still sync delays.

Temporary solution to update affected Datablocks and re-sync data:
1. Navigate to the Datablock with outdated values.
2. Open Advanced Settings, where data should update.
3. Close Advanced Settings, and
4. Refresh the page

Here's a short recording with the above steps: https://www.loom.com/share/3a7b192722224851bac68ef8da21a6ec
Posted Oct 13, 2020 - 13:19 EDT
Identified
We identified the cause and are working on resolving it.

Temporary solution to update affected Datablocks and re-sync data:
1. Navigate to the Datablock with outdated values.
2. Open Advanced Settings, where data should update.
3. Close Advanced Settings, and
4. Refresh the page
Posted Oct 12, 2020 - 07:13 EDT
Investigating
We are experiencing syncing delays for Data Sources where Custom Date Range is enabled. We are investigating this with the highest priority.

Affected Data Sources: Google Analytics, Google Ads, Google Search Console, Google My Business, Facebook Pages, Facebook Ads, Instagram Business, Twitter, LinkedIn Company Pages, Ahrefs.

Connecting new Data Sources is working as expected. Data Sources that don't have Custom Date Range enabled are not affected and are syncing as expected.
Posted Oct 12, 2020 - 03:47 EDT
This incident affected: Data & Sync Platform.