Resolved: Delays when opening Databoards
Incident Report for Databox
Resolved
Yesterday, on April 14th, starting at 2:19 PM EDT, we experienced temporary loading delays on one of the services, responsible for displaying the data on Databoards. The issue was resolved at 2:50 PM EDT.

We’ve resolved the incident and are already working on implementing improvements to prevent any similar occurrences in the future.
Posted Apr 15, 2021 - 03:17 EDT
This incident affected: Databox Web Application.