Loading issues with our Knowledge base on our host's end (help.databox.com)
Incident Report for Databox
Resolved
The issue has been resolved by the host and our Knowledge base is working as expected again.
Posted Dec 02, 2019 - 12:40 EST
Update
We have identified the source of the issue which lies on our host's end. They have shared a status on their status page: https://status.helpscout.com/
Posted Dec 02, 2019 - 11:07 EST
Identified
It seems that there are loading issues on the host's end for our Knowledge Base accessible at help.databox.com.

We have already reached out to them and are waiting for a resolution on this.
Posted Dec 02, 2019 - 11:01 EST