Issues with logging in to app.databox.com
Incident Report for Databox
Resolved
We have successfully resolved the issue. Affected were users who tried to login in the last 1 hour.

The issue was caused by the SSL intermediary root certificate being expired which is now resolved.
Posted May 30, 2020 - 09:07 EDT
Investigating
We are experiencing temporary issues with some users not being able to login into Databox (app.databox.com).

We are still investigating this.
Posted May 30, 2020 - 09:04 EDT
This incident affected: Databox Web Application.